Project

General

Profile

problems with send files

Added by Niggu Rath over 7 years ago

hello, i'm using router, i've been open ports and add iroffer application, but still doesn't sending....
i tried to use usenatip with my public ip....nothing.....someone knows what's going on??? thanks


Replies (7)

RE: problems with send files - Added by Dirk Meyer over 7 years ago

You have this options:

1. UPNP
Check your router. Try to enable UPNP, and uses in your config "upnp_router" and "getipfromupnp"

2. FIXED NAT
Set "usenatip" with your public IP.
Set "tcprangestart 4000"
Configure your router to forward Ports 4000 to 4010 to your local IP, same port.

3. DYNAMIC NAT
Use all the settings from (2).
Add "getipfromserver" if your network support this function (rizon does not).

4. Testing
Please test from outside!
It is almost impossible to make iroffer work local and external at the same time.

You might enable "debug 3" to see what is going wrong.
Please check your logfile for warnings and errors.

RE: problems with send files - Added by Niggu Rath over 7 years ago

thanks a lot, i've been open a new port on router with upnp.
i've included lines "upnp_router" and "getipfromupnp" but's a wrong message comes....ignore lines, command unknown
and......on the 2nd option usenatip + tcprangestart.....
now everything's ok, thanks again :)

RE: problems with send files - Added by Niggu Rath over 7 years ago

ops....something strange.....i'm logged with mirc + iroffer.....after a time, both are stopping to send files.....always i have to remove ports on router and add again.....details....
open ports on mirc are tcp 1024 til 7000 udp 58 to 133
open ports on iroffer are tcp /udp 3500 to 4500....
can be port conflict?

RE: problems with send files - Added by Niggu Rath over 7 years ago

sorry on iroffer are between 7500 to 8500

RE: problems with send files - Added by Dirk Meyer over 7 years ago

Niggu Rath wrote:

thanks a lot, i've been open a new port on router with upnp.
i've included lines "upnp_router" and "getipfromupnp" but's a wrong message comes....ignore lines, command unknown

You should add "-upnp" when running Configure. e.G:
./Configure -curl -geoip -ruby -upnp

RE: problems with send files - Added by Dirk Meyer over 7 years ago

Niggu Rath wrote:

ops....something strange.....i'm logged with mirc + iroffer.....after a time, both are stopping to send files.....always i have to remove ports on router and add again.....details....
open ports on mirc are tcp 1024 til 7000 udp 58 to 133
open ports on iroffer are tcp /udp 3500 to 4500....

No conflict here.
But the DCC stops working when you get a new public IP on your router.

1. UPNP
UPNP will take care of this.

2. getipfreomserver
Try "getipfromserver" in your config

3. manual update
You have to update "usenatip" in your config when you get a new ip.
You might use the script "dynip.sh" and modify it for your bot.
The start the script every 5 minutes via crontab.

RE: problems with send files - Added by Niggu Rath over 7 years ago

thank you very much Dirk !!! You are a ninja !!!

    (1-7/7)